/ Support

DocVelocity Internet Browser support for TLS 1.2

Effective February 1, 2017, all Capsilon customers must utilize a browser supporting TLS 1.2 or higher.  Capsilon will be disabling TLS 1.0 and TLS 1.1 by January 31, 2017. This action is being taken to mitigate exposure to the Browser Exploit Against SSL/TLS (BEAST).   Site users will also be required to accept a new DocVelocity or Imagility Desktop client that supports TLS 1.2.  Capsilon will notify you when your Desktop client is available.

Supported browsers include:

  • Google Chrome version 32 and higher
  • Mozilla Firefox version 33 and higher
  • Internet Explorer 11 *Versions 10 & 9 can be configured to support TLS 1.2 but do not do so by default.
  • Microsoft Edge 14 or 13
  • Opera version 18 or higher
  • Apple Safari 9 or higher

 If you have questions or need assistance, please contact Capsilon Customer Support by submitting a ticket on the Capsilon Support Portal or by calling 877-362-8356.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.